pryでrequireしたgemのVersionを確認する && Resqueの話

Resqueの最新版を調査していた所、新しいResqueのVersionで使えるはずの記法(Resqueをクラスメソッドじゃなくて、インスタンス生成する)が使えず、妙に変だな〜という話になった。

requireしているGemのVersionを確認するには、以下のようにして確認できる

[1] pry(main)> require 'resque'
true
[2] pry(main)> Resque::Version
"2.00pre"


Resqueの2系


どうやら2系はまだopenになっていないらしく、1系のstableを使えというのがコントリビュータの見解らしい

Does Resque 2.0.0 work or not? · Issue #1107 · resque/resque
https://github.com/resque/resque/issues/1107